Documentation

Format and Export Documents and Graphics

Format Text

Choose Font Style, Size, and Colors

To change the font for a particular piece of text:

  1. Select text that you want to format.

  2. Select Format>Characters from the main menu or use context menu.

  3. In the Character Format dialog box choose the font style, font size, font and background colors, and effects. The window at the bottom of the dialog box shows a preview of your changes.

    If you want to experiment with different fonts, and see how the formatted text looks in your notebook, click the Apply button. This button applies formatting to the selected text and leaves the Character Format dialog box open. You can change font and color of your text several times without having to open this dialog box for each change. When you finish formatting, click OK to close the Character Format dialog box.

To format selected text, you also can use the Format toolbar. If you do not see the Format toolbar, select View>Toolbars>Format from the main menu.

To change the font size quickly, you can use Format>Increase Size and Format>Decrease Size or the corresponding buttons on the Format toolbar.

Choose Indention, Spacing, and Alignment

To change paragraphs settings such as indention, spacing, alignment, and writing direction:

  1. Select the paragraphs you want to format.

  2. Select Format>Paragraph from the main menu or use the context menu.

  3. In the Paragraph Format dialog box choose indention, spacing, alignment, background color, and writing direction of the text. The writing direction is a language-specific option that allows you to type from right to left.

    If you want to experiment with different paragraph settings, and see how the formatted text looks in your notebook, click the Apply button. This button applies formatting to the selected text and leaves the Paragraph Format dialog box open. You can change paragraph settings several times without having to open this dialog box for each change. When you finish formatting, click OK to close the Paragraph Format dialog box:

Format Mathematical Expressions

You can change font style, size, and color of mathematical expressions in text regions in the same way you format regular text. See Choosing Font Style, Size, and Colors for more details.

For additional formatting of mathematical expressions:

  1. Select Format > Math.

  2. Set your formatting preferences. You can define the script size, choose between inline (embedded in text) or displayed styles, and use the Slant identifiers check box to italicize variables. Also, you can specify whether you want to wrap long mathematical expressions to a notebook window size.

    If you want to experiment with different settings for mathematical expressions and see how the formatted expression looks in your notebook, click Apply. This button applies formatting to the selected text and leaves the Math Format dialog box open. You can change settings several times without having to open this dialog box for each change. When you finish formatting, click OK to close the Math Format dialog box.

Format Expressions in Input Regions

You can change font style, size, and color of mathematical expressions in Text regions in the same way you format regular text. See Choosing Font Style, Size, and Colors for more details.

For additional formatting of commands and expression in the input regions:

  1. Select Format>Calculation in the main menu.

  2. Set your formatting preferences. You can define indentation, spacing at the top and bottom of the calculation, and width of the left bracket that encloses the input region.

    If you want to experiment with different settings for input regions, and see how the formatted expressions and commands look in your notebook, click the Apply button. This button applies formatting to the selected region and leaves the Calculation Format dialog box open. You can change settings several times without having to open this dialog box for each change. When you finish formatting, click OK to close the Calculation Format dialog box.

Change Default Format Settings

If you want to apply a specific format to the whole notebook, you can change the default settings for particular types of regions. For example, to change default setting for all commands and expressions in the input and output regions of a notebook:

  1. Select Format > Defaults from the main menu.

  2. In the resulting dialog box, use tabs to select the required element. For input and output regions, select the Calculations tab.

  3. From the drop-down menu Format select Input and Output.

  4. In the appropriate fields, enter values for the size of indentation, the spacing at the top and bottom of the calculation, and the width of the left bracket that encloses each input and output region.

  5. Click OK to apply the new default settings and close the Default Formats dialog box.

Use Frames

If you want to format different parts of a notebook separately, use frames. Frames can include text, mathematical expressions, and commands. To insert a frame:

  1. Select the place where you want to insert a frame.

  2. Select Insert>Frame.

  3. Drag the selected part into the frame.

You can change the appearance of the frame. To format a frame:

  1. Place cursor inside the frame you want to format.

  2. Select Format>Frame from the main menu or right-click to use context menu.

  3. In the appropriate fields of the Frame Format dialog box, type the size of left margin, frame border size, width of the left bracket that encloses the input region, and background color.

  4. Click OK to apply the new frame settings and close the Frame Format dialog box.

Use Tables

Create Tables

To insert a table in a notebook:

  1. Select the place where you want the table to appear.

  2. Select Insert>Table.

  3. In the resulting dialog box, select the number of columns and rows and click OK.

Add and Delete Rows and Columns

To add a row or column to an existing table or delete an existing row or column:

  1. Click a cell where you want to add or delete a row or column.

  2. Select Edit>Table from the main menu and select the required action.

    If you inserted a row, it appears above the row with the selected cell. If you inserted a column, it appears to the left from the selected cell.

Format Tables

You can change the appearance of a table in a MuPAD® notebook. To format a table:

  1. Click the table you want to format.

  2. Select Format>Table from the main menu.

  3. In the Table Format dialog box, select your settings:

    PositionText wrapping
    MarginsCell margins (all margins have the same size.)
    PaddingDistance between the text and the border of a cell
    BorderWidth of the line used to draw cell borders
    SpacingSpace between the cells
    BackgroundBackground color of the cells

    If you want to experiment with different settings, and see how the formatted table looks in your notebook, click the Apply button. This button applies formatting to the selected table and leaves the Table Format dialog box open. You can change settings several times without having to open this dialog box for each change. When you finish formatting, click OK to close the Table Format dialog box.

Embed Graphics

To insert a picture into a text region:

  1. Select the place in a text region where you want to insert a picture.

  2. Select Insert>Image from the main menu and browse the image you want to insert in a notebook.

  3. The selected image appears in the original size. You cannot format images in text regions of a notebook.

Create Link Targets.  You can insert a link to a particular location in the same notebook or in some other MuPAD notebook. This location is called a link target. First, use the following procedure to create a link target:

  1. Open the notebook in which you want to create a link target.

  2. Select the part of the notebook that you want to use as a link target. You can select any object in a notebook, except for output regions.

  3. Select Insert>Link Target to declare the selected part of a notebook as a link target. Alternatively, use the context menu.

  4. In the Create Link Target dialog box, type the name of the link target.

  5. Save the notebook that contains the link target.

Add Links.  To associate a link with a link target:

  1. Open the notebook in which you want to insert a link. This notebook can be the same one where you defined the link target, or it can be any other notebook.

  2. Select the part of a notebook where you want to create a link.

  3. Select Insert>Link from the main menu or use the context menu.

  4. In the Create Hyperlink dialog box, select MuPAD Document and the name of the notebook that you want to link to. The Targets list displays all link targets available in the selected notebook.

  5. In the Targets list, select the link target that you want to use. If you want to create a link to the top of the notebook, select TOP.

To insert a link to a MuPAD notebook interactively (without choosing and naming the target in advance):

  1. Open the notebook in which you want to insert a link.

  2. Select the part of a notebook where you want to insert the link.

  3. From the context menu select Insert link interactively.

  4. The following dialog box appears. To continue creating a link, click OK.

  5. Open the notebook where you want to insert the link target. If you create a new notebook, save it before proceeding.

  6. Select the part of the notebook to which you want to link.

  7. Right-click the selected part. From the context menu, select Interactive link to this point.

To insert a link to any file on your computer:

  1. Select the part of a notebook where you want to insert a link.

  2. Select Insert>Link from the main menu or use the context menu.

  3. In the Create Hyperlink dialog box select Existing File.

  4. Select the file you want to refer to. To select the file, enter the file name in the Link to field or choose the file from the history list. Alternatively, click the Open File button , and then browse for the file.

To insert a link to an Internet address:

  1. Select the part of the notebook where you want to insert a link.

  2. Select Insert>Link from the main menu or use the context menu.

  3. In the Create Hyperlink dialog box, select Internet.

  4. Type an Internet address and click OK. For example, insert a link to the Web page.

To insert a link to an e-mail address, type mailto: before the address.

To edit a link:

  1. Select the link that you want to edit.

  2. Select Edit>Link from the main menu or use the context menu.

  3. In the Edit Hyperlink dialog box, edit the link. You can change the display text or the link target or both.

To delete a link:

  1. Select the link that you want to delete.

  2. Right-click to open the context menu.

  3. Select Remove Link

Alternatively, you can use the Edit Hyperlink dialog box to delete a link. To delete a link by using the Edit Hyperlink dialog box:

  1. Select the link that you want to edit.

  2. Select Edit>Link from the main menu or use the context menu.

  3. In the Edit Hyperlink dialog box, click the Remove Link button.

  4. Click OK.

If the list of link targets is very long, finding the correct link target can be difficult. To make this list shorter, delete link targets that you do not use. To delete a link target:

  1. Find the link target in a notebook. To highlight all link targets in a notebook, select View>Highlight Link Targets.

  2. Select the link target that you want to delete.

  3. Select Insert>Link Target from the main menu or use the context menu.

  4. In the Edit Link Target dialog box, click Delete.

Export Notebooks to HTML, PDF, and Plain Text Formats

To export a notebook to HTML, PDF, or plain text format:

  1. Select File>Export from the main menu.

  2. From the drop-down menu, select the file format to which you want to export a notebook.

  3. In the Export Notebook dialog box, enter a name for the file and click Save.

If you export a MuPAD document with links to PDF format, these links are replaced by regular text in the resulting PDF file.

Save and Export Graphics

Export Static Plots

To save the resulting plots separately from a notebook:

  1. Double-click the plot you want to export. Select File>Export Graphics from the main menu or right-click to use the context menu.

  2. Click Next in the Graphics Export Guide dialog box.

  3. Select the file format to which you want to export the image.

  4. The next steps depend on the file format you selected. Follow the instructions in the Export Graphics dialog box.

Choose the Export Format

The appearance of your exported graphics, its quality, and compatibility with other documents depend on the file format you select for saving graphics. The set of file formats available for exporting graphics from a MuPAD notebook could be limited by your operating system and by the type of image.

Vector Formats.  You can save an image as a set of vector objects such as lines and geometric figures. Images in vector formats are resolution independent and scale almost without quality loss. These images can look different on different computers. MuPAD supports the following vector graphics formats:

  • XVC/XVZ — the MuPAD native format. You can import the images saved in this format into a notebook and activate and manipulate them with the MuPAD notebook graphic tools.

  • JVX/JVD — JavaView. Java® based format for 2-D and 3-D images that you can embed into HTML Web pages. Exporting an animation to JavaView, you can choose to export the current view or a sequence of images.

  • EPS — Encapsulated PostScript®. Standard format for publishing images in scientific articles and books. This format serves best for 2-D images. 3-D images are exported as raster images embedded in EPS, and, therefore, can loose quality. You cannot export animations to this format.

  • SVG — Scalable Vector Graphics. The format serves for including vector graphics and animations on Web pages. MuPAD does not support svg animations. You can only export the current view of an animation in this format. You cannot export 3-D images to this format.

  • WMF — Windows® Metafile. You can use this file format on Windows operating platforms only.

  • PDF — Portable Document Format. You can use this format to export non-animated 2-D images.

Bitmap Formats.  Bitmap formats save an image pixel by pixel allowing the image to look identical on different computers. To save images in bitmap format, you need to select the image resolution. The quality of images saved in bitmap formats depend on the resolution and can be decreased if you scale an image after saving. MuPAD supports the following bitmap graphics formats:

  • PNG

  • GIF

  • BMP

  • JPEG

Save Animations

You can export an animation created in MuPAD into an animated GIF file. If you use a Windows systems, you can export an animation created in MuPAD into the special format AVI . To save an animation in this format, select a compressor from the list of compressors available for your animation and operating system.

A compressor defines the size of the exported animation and the quality of images in the animation. Viewing the exported animation requires the installation of an appropriate compressor.

Export Sequence of Static Images

You can export an animation as a sequence of static images. For example, the following calculations result in an animated plot:

plot( plot::Function2d( sin(x) ), 
      plot::Point2d( [x, sin(x)], x=-5..5 ), 
      plot::Line2d( [x,-1], [x,1], x=-5..5, LineStyle=Dashed),
      plot::Line2d( [-5,sin(x)], [5,sin(x)],
                  x=-5..5, LineStyle=Dashed)
)

To export the resulting plot:

  1. Select File>Export Graphics from the main menu or right-click to use the context menu.

  2. Click Next in the Graphics Export Guide dialog box.

  3. Select Export whole animation sequence and click Next.

  4. Select the format for saving images of the sequence and the file name. A sequence of numbers automatically appends to the file name you enter. For example, when you enter image.jvx, you get the following sequence of files: image.1.jvx, image.2.jvx, and so on. This sequence of file names displays below the entry field for the file name.

  5. Select the number of frames per second. This number defines the total number of image files you create.

Was this topic helpful?