Creating a backwards compatable p-code file

1 view (last 30 days)
I am teaching some matlab classes and we have some version-ing issues ... some students use versions as old as 2008b and some of the computers in the lab have versions as old as 2007a. I want to create some pcode files which will run on all of these versions ... that way they can check their results without seeing the actual code that created them.
I know that Matlab 2010a (the version I use daily) can operate pcode files made from any previous version but the older versions can't run pcode made with my computer.
Is there any way to create backwards compatible pcode files? I know I can just find the oldest version and make a pcode on that computer and distribute it ... but that's really annoying.
Thanks, Will

Accepted Answer

Shivam
Shivam on 30 Jul 2022
Documentation mentions:
The pcode algorithm was redesigned in MATLAB 7.5 (Release R2007b). You can run older P-files in any current version of MATLAB; however, upcoming releases will not run P-files created before version 7.5. Files generated in 7.5, or later versions, cannot run in MATLAB 7.4 or earlier.
(Use docsearch pcode to view, expand "More about, Tips").
Based on the insufficient tips and help, I doube that pcode cannot be transitioned either way between pre-2007a and post-2007b.

More Answers (0)

Categories

Find more on Programming Utilities in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by