Missing text objects when exporting graphics in R2022b

3 views (last 30 days)
Since upgrading to R2022b, I've repeatedly run into an inssue in which text objects, legends, titles, etc do not get printed, or their position is shifted significantly when I export graphics via exportgraphics or export_fig. I'm trying to find some sort of rhyme or reason, but the problem seems somewhat inconsistent. It may only occur with OpenGL, but I'm not entirely sure.
Is this a known problem? Is there a known fix?
I'm using a MacOS Monterey 12.6.1.
  1 Comment
Ben Henley
Ben Henley on 19 Jan 2023 at 4:55
I'm getting the same problem as @Chad Greene on R2022b, MacOS Monterey 12.6 using export_fig. @Manas Shukla can you please provide an update? Thanks!

Sign in to comment.

Answers (1)

Manas Shukla
Manas Shukla on 15 Nov 2022
This issue can be mapped to the graphics drivers. The issue can be resolved by trying the following:
  1. Updating the driver.
  2. Switching to 'software' or 'hardwarebasic' opengl. The limitations of using the above settings can be found in this link: https://www.mathworks.com/help/matlab/ref/opengl.html?searchHighlight=opengl%20version&s_tid=doc_srchtitle#buwqhi1-8
  1 Comment
Chad Greene
Chad Greene on 17 Nov 2022
@Manas Shukla I'm afraid none of these solutions are viable.
Updating the driver: I'm not entirely sure what you mean by this, but I looked up how to update OpenGL on a Mac, and the google pretty much says it can't be done.
Switching to 'software': The opengl documentation says "This option is not available on Macintosh systems."
Switching to 'hardwarebasic': I tried opengl('save','hardwarebasic'), but the problem persists.

Sign in to comment.

Categories

Find more on Printing and Saving in Help Center and File Exchange

Products


Release

R2022b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by