MATLAB Answers

0

AsbQuadCopter simulation-not taking custom reference position as input (Parrot Mambo)

Asked by Jasvir Virdi on 18 Feb 2019
Latest activity Commented on by Jasvir Virdi on 19 Feb 2019
Hello,
I am trying to give a custom input to the asbQuadCopterStart simulation. (Please check the attached image). I am using signal builder for this purpose. Since the "pos_ref" at the AC_cmd side takes a vector of position (x,y,z), I have used mux to combine the signal builder outputs and then used it as an input to the AC_cmd bus. However, an error is reported everytime I run this.
The error is as follows:
"The input bus to block 'asbQuadcopter/Command/Signal Editor/Bus Creator' does not match the bus specified by the bus object 'CommandBus' on the block dialog : Signal 'signal2' does not match the name 'CommandBus.pos_ref' of the corresponding bus element in the bus object. To disable this diagnostic, set the Configuration Parameters > Diagnostics > Connectivity > 'Element name mismatch' option to 'None'. [4 similar]"
I feel because of this, the simulation is running incorrectly. Please could you clarify what is going wrong.
I have also attached the bus_block image for your reference. At the point where it shows signal_2, I feel it should be pos_ref so that the program runs currectly. I have tried the over ride command (specified in the block), but still it does not work

  1 Comment

Does anyone have ideas why the signal builder can't be connected to the bus? How do I work around that? Is signal editor the only option?

Sign in to comment.

0 Answers