Removed Support for Certain Functions in MATLAB Grader?

4 views (last 30 days)
I am reusing a MATLAB Grader assignment from previous semesters for my students this term, and it seems like some functions are no longer supported. In the below code, view() and train() are no longer supported, but were supported in the past.
%% compare with patternnet
net = patternnet(4,'trainscg','crossentropy');
net = configure(net,X,Y);
view(net);
%% output from randomly initialized net
rng(1);
net = init(net);
Yest = sim(net,X);
figure(5);
plot(Yest);
%% train it!
net.trainParam.max_fail = 200;
%net.trainParam.epochs = 10000;
[trainedNet, history] = train(net, X, Y);
Are there release notes for the list of functions or toolboxes the current MATLAB Grader version supports and no longer supports?

Accepted Answer

Cris LaPierre
Cris LaPierre on 3 Apr 2022
Edited: Cris LaPierre on 3 Apr 2022
The error I get when running a similar example in Grader is
Error using matlab.internal.lang.capability.Capability.require
This functionality is not available on remote platforms.
The view and train commands call interactive elements that are not supported in MATLAB Grader. If this used to work, then it appears a new check has been added that does not explicitly ban the use of these two functions, but does throw an error whenever interactive elements are called within Grader. I suggest reporting this change in functionality to MathWorks Support so they can investigate further.
  1 Comment
Nathan You
Nathan You on 3 Apr 2022
The view and train comands did work previously with view giving only an image of network connections and train running without the GUI that appears by default on the desktop version. As a fix, view was omitted and
net.trainParam.showWindow = false;
was placed before the train command. Thanks for the insights

Sign in to comment.

More Answers (1)

Jeff Alderson
Jeff Alderson on 3 Apr 2022
Edited: Walter Roberson on 3 Apr 2022
When creating your new course, did you remember to add the required toolboxes to your course? What MATLAB error messages do you see when you run your code? If it says function could not be found, you most likely need to add the toolboxes you require on your course settings.
  1 Comment
Nathan You
Nathan You on 3 Apr 2022
The Signal Processing and Deep Learning Toolboxes were added for the course already. These were also the minimum required toolboxes to get the code to run properly. The error codes were similar to the ones in Chris's response, and it is likely due to a change in functionality for the current MATLAB Grader version.

Sign in to comment.

Communities

More Answers in the  Distance Learning Community

Categories

Find more on Get Started with MATLAB in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by