Permission error for PREFDIR when running a stand-alone application on a different system

3 views (last 30 days)
I am trying to run a stand-alone application compiled on Linux on another Linux system. However, I am running into issues because it seems like at some point the Matlab preference folder is being accessed. However, since this folder does not exist on this system, it returns an error. I am now wondering why prefdir is included in the compiled version and how I can circumvent the stand-alone application to rely on it.
Unable to access preferences folder /home/[USERNAME]/.matlab/R2022a. Preferences folder must be writable.
Thank you!

Sign in to comment.

Answers (2)

Jan on 9 Mar 2023
If the preferences folder is hardcoded, such problems occur. Search in the code for the name of the folder an replace it by the command prefdir.
Clara on 10 Mar 2023
Hmm, okay, then I'll need to play around with it a bit more.
Let me know in case you have other ideas what might cause this issue!
Just to make sure, I tried a helloworld compiled script and that worked fine.. The error seems to occur when trying to open the actual compiled standalone application but it does not even run the first line of the main function since it would otherwise execute a print command.

Sign in to comment.

Clara on 11 Mar 2023
Edited: Clara on 11 Mar 2023
I think I was abble to fix it by adding
"-R -nodisplay or -R -nojvm" during the compilation!
However, I was just trying out things so it is not really clear to me why this helped. Do you have an idea why? (also I haven't tested yet whether only on of the two or both were necessary, I assume I'd only need the -nodisplay option). I'll update that once I tried it.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by