Azzera filtri
Azzera filtri

Unreal Project simulation works but executable does not

3 visualizzazioni (ultimi 30 giorni)
I created a custom scene in Roadrunner, imported it into Unreal 4.26. Made sure the plugins are enabled and then ran the simulation through Simulink connecting the 'Simulation 3D Scene Configuration' to the .uproject file and it worked.
Then I exported the executable and tried to connect the simulink model to the executable, but unreal crashed giving the "Assertion != nullptr" error(screenshot attached).
I would be very grateful to any guidance. Thanks!
I am attaching the screenshot of the plugins that I have installed in Unreal - I dont know if I have correctly installed the 'MathWorks Automotive Content' plugin. Please let me know!

Risposte (1)

Yoga
Yoga il 2 Ago 2023
When using Unreal, it is important to ensure that the MATLAB, Unreal versions, and the MathWorks Unreal plugins are synced properly. This is especially true when running multiple versions from the same computer or migrating releases.
Check the Unreal Crash for "UE4Editor_MathWorksSimulation". This indicates that there may be an issue related to the plugin, so gather the uproject and relevant files and escalate the issue.
The crash will look similar to the following, and can be located at <File Path to Project Folder>\<Project Name>\Saved\Logs:
After ensuring that these products are compatible, Unreal may still crash if you have not recently reparented. Follow the steps from the following to ensure that the link between Simulink and Unreal is generated correctly - Install Support Package for Customizing Scenes - MATLAB & Simulink (mathworks.com).
This message also indicates that applying mesh of Vehicle actor failed because UE cannot find some files.
Please confirm that you have enabled MathWorks Automotive Content plug-in.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by