Azzera filtri
Azzera filtri

Simulink model is not communicating with EtherCAT device despite no errors

3 visualizzazioni (ultimi 30 giorni)
I have a simulink model that should connect to an EtherCAT slave device, write a sine wave to that device's analog out, and read the device's analog in to a scope (the analog in is wired to the analog out). The EtherCAT device is being initialized with the EtherCAT init block; I've supplied the correct ENI file, and everything in the model seems correct. When I run the model, there are no errors, but the scope on the analog in is a flat line. When I look at the analog in or out with TwinCAT or with a multimeter, I can see that no change is being made. My best guess for what the issue is is maybe the distributed clock is miconfigured, though I feel like I've tried every configuration of settings that are available.
How can I troubleshoot this issue and how can I get it so Matlab actually communicates with the EtherCAT device?

Risposte (1)

Jan Houska
Jan Houska il 29 Lug 2023
Hi,
Simulink Desktop Real-Time has no EtherCAT support that I know of. If you are using EtherCAT blocks from a library of a different product, chances are that these blocks are specific to that product or target and do not work with Simulink Desktop Real-Time at all.
Best Regards, Jan

Prodotti


Release

R2022b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by