Azzera filtri
Azzera filtri

why parameterized MOSFETs simulation doesn't run

4 visualizzazioni (ultimi 30 giorni)
I have been trying to model a single phase inverter using simscape for now, when I use MOSFET (Ideal/Switching) block, the simulation runs fine, but I need to model a non-linear inverter by parameterizing the N-channel MOSFETs. Firstly, I tried to parameterize the MOSFET according to the datasheet, but the simulation was showing error such as,
"Solver was unable to reduce the step size without violating minimum step size of 1.83569E-15 for 1 consecutive times at time 0.5167. Solver will continue the simulation with the step size restricted to 1.83569E-15 and using an effective relative error tolerance of 0.0015818, which is greater than the specified relative error tolerance of 0.001. This usually may be caused by violating algebraic constraints in the differential-algebraic system or by the high stiffness of the system. Try tightening the error tolerances, and/or the tolerances for computing consistent conditions. If the problem persists, please check the system or increase the solver Number of consecutive min steps violation parameter."
It says open solver profile to resolve, but I'm unabale to understand the solver settings, Now, I haven't parameterized, but the used the same parameters that are already includes in N-channel MOSFET, the issue is still the same.
Looking for your guidance on this matter, as I'm relatively new MATLAB User.
Thank you.

Risposta accettata

Arka il 27 Dic 2023
I understand that you are facing an error with the step size during simulation of a model containing N-channel parameterized MOSFET blocks in Simulink.
It is difficult to provide you a specific answer without investigating the actual model, but one of the instances when this error can occur is when the solver is unable to solve the system/model within the step-size provided.
One of the recommended ways to resolve this error is to increase the number of consecutive minimum steps the model is taking. This value can be modified by expanding the "Additional options" section in "Solver Section" of the "Configuration Parameters" menu.
In this section, you should see a dialog box with the title "Number of consecutive min steps:" next to it. You can try to increase the value in this box.
You can also try to relax all the tolerances in the model from the model's "Configuration Parameters".
Alternatively, if this does not fix the issue, you can also try changing the solver being used, possibly to ode23t (if not using it already).
Hope this helps!
  2 Commenti
Hassan Ali
Hassan Ali il 28 Dic 2023
Thank you @Arka, the issue is resolved, sometimes it happens again when I try to run the simulation for longer time , but then again increaisng the consecutive min steps, resolves the issue.
Arka il 28 Dic 2023
Hi @Hassan Ali, glad to know that this worked for you!

Accedi per commentare.

Più risposte (0)




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by