Azzera filtri
Azzera filtri

Error in READWRITE mode of

8 visualizzazioni (ultimi 30 giorni)
I'm trying to read a FITS file in READWRITE mode but keep getting a "could not open file" error. I get no error in READONLY mode and the file reads correctly.
The code is simple: fptr ='filename.fits','readwrite')
The error is:
Error using matlab.internal.imagesci.fitsiolib
CFITSIO library error (104): could not open the named file
I get the same error when trying to read a file with an image HDU or with a binary-table HDU.
I've reset all the permissions on the file so that it is rwxrwxrwx (no ambiguity on what the permissions are) and get the same error. Any ideas about how to fix this?
Thank You.
  1 Commento
Walter Roberson
Walter Roberson il 3 Gen 2024
Is the file in the current directory? Is it named exactly 'filename.fits' (not, for example, 'filename.FITS') ?

Accedi per commentare.

Risposte (3)

Dinesh il 4 Gen 2024
Ensure no other processes, including MATLAB instances, are accessing the "filename.fits" file, as this can prevent opening it in "readwrite" mode. Trying to open a different FITS file or creating a new one can help determine if the issue is file-specific or a broader permission issue.
If the problem still persists, ensure that the file is actually present in the relative path. Verify the file's directory permissions and the file system's write access once again. Also, check for typos and incorrect file extensions.

Ayush il 4 Gen 2024
Modificato: Ayush il 4 Gen 2024
I understand that when you are trying to read a FITS file in READWRITE mode you are getting a "could not open file" error. I could reproduce the error when my filename consists of brackets () for R2022b release. However, this error seems to be fixed for R2023a release.
Check to see if your filename consists of some other such special characters. Rename the filename to remove such special characters.

jvaillancourt il 5 Gen 2024
Thanks for all the replies folks. The problem was not anything to do with the file name, or even permissions perhaps. And the problem did not occur on all FITS files (with similar data, names, and permissions). After re-starting MatLab several times the problem disappeared. I had one colleague who was able to re-produce the problem intermittently and another who never had any problems. ¯\_(ツ)_/¯


Scopri di più su File Operations in Help Center e File Exchange




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by