MATLAB Answers

0

browser integration with MATLAB (Fedora 16 64bit)

Asked by Michal Kvasnicka on 27 Feb 2012
When I launch the following command: system('firefox')
or try to open anything related to web browser from MATLAB (for example Help-Web Resources-...)
I always get the folowing error message:
XPCOMGlueLoad error for file /usr/lib64/xulrunner-2/libxpcom.so: /usr/local/MATLAB/R2011b/sys/os/glnxa64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib64/xulrunner-2/libxul.so) Couldn't load XPCOM.
With google-chrome I got very similar error message: system('google-chrome')
/usr/bin/google-chrome: /usr/local/MATLAB/R2011b/sys/os/glnxa64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/bin/google-chrome)
But both browsers works perfectly outside of MATLAB.
Any help?

  1 Comment

when I create the soft link:
/usr/local/MATLAB/R2011b/sys/os/glnxa64/libstdc++.so.6 -> /usr/lib64/libstdc++.so.6.0.16
the firefox works without any problem, but google-chrome produce following error message:
system('google-chrome')
/opt/google/chrome/chrome: error while loading shared libraries: libfreetype.so.6: failed to map segment from shared object: Permission denied

Sign in to comment.

0 Answers