Error using xlsread (line 249) Excel Worksheet could not be activated.

1.048 visualizzazioni (ultimi 30 giorni)
Error using xlsread (line 249) Excel Worksheet could not be activated.
whenever I try xlsread, it just gives me this error I've tried reinstalling, but still did not work.
  3 Commenti
S Deligeorges
S Deligeorges il 31 Mar 2021
Modificato: S Deligeorges il 31 Mar 2021
I have slight variatiuon on the problem. using Matlab R19b, windows 10. I can open an excel file once with xlsread, but every time after that I get the line 249 error. clear all does not fix it, restarting matlab does not fix it, rebooting the machine does not fix it. Matlab touching the file once had made all my data unreadable by Matlab. Any suggestions ?
mehmet utku
mehmet utku il 21 Apr 2023
Modificato: mehmet utku il 21 Apr 2023
clear all worked for me thank you.

Accedi per commentare.

Risposte (12)

Tobias Elve
Tobias Elve il 6 Mag 2020
Modificato: Tobias Elve il 6 Mag 2020
A 'clear all' does the trick; without restarting MATLAB
  7 Commenti

Accedi per commentare.


Ismaeel
Ismaeel il 4 Ago 2018
I had the same problem. After closing-reopening MATLAB, it worked just fine. I have no add-in plugin in Excel.
  1 Commento
KAE
KAE il 30 Mag 2019
Modificato: KAE il 30 Mag 2019
I get this problem when I have to stop a Matlab script (CTRL-C) which opens a large Excel file. The next time I run the script, it crashes and says 'Excel Worksheet could not be activated'. If i restart Matlab, it is resolved, but that is inconvenient. I'm using R2019a and I believe it was occuring in R2018b and possibly earlier. I have no Excel plugins that I know of.

Accedi per commentare.


Walter Roberson
Walter Roberson il 6 Ott 2016
I have been wondering if this has to do with Excel plugins:
"Certain Excel add-ins may also prevent proper termination of Excel. Some known add-ins that might cause issues are Broadcom's "Send to Bluetooth" add-in (btsendto_office.dll) and Bloomberg's TaskpaneHost add-in. Disabling the add-ins that cause issues is a possible workaround."
There have been other reports having to do with Excel plugins that I cannot seem to find at the moment. I suggest going into Excel and seeing if you have any plugins active, and if you do then disabling them and then trying again in MATLAB.
  2 Commenti
Walter Roberson
Walter Roberson il 16 Dic 2016
Another plug-in often mentioned as being a problem is Foxit.
Zaiyang ZHOU
Zaiyang ZHOU il 11 Lug 2018
MATLAB R2016b + OFFICE 2016. My problem seems a little bit different. Everytime I use 'xlsread', MATLAB will stop running but without any error information, just keep in the state of 'Busy'. Then I find a background process of Excel is activated, I manually delete the Excel process, and MATLAB runs normally, and data will be imported in. But I have been driven mad for deleting the process manually, especially when I read more than one .xls or .xlsx file.

Accedi per commentare.


Rambod Naimi
Rambod Naimi il 10 Nov 2016
I am having similar issues with the Excel. I think i have narrowed it down to the fact that it takes longer than 5 seconds on my machine to open the file. there is a actTimeout which is internal to matlab. I don't know how to increase this value to check. but the message is coming from openExcelWorkbook.m file line 33. so i think this is the main issue with some PC's, the time to create a file and verify it was successful is longer than 5 seconds! I have popped the question to mathworks, hope they can answer!
  2 Commenti
K E
K E il 16 Dic 2016
Modificato: K E il 16 Dic 2016
Please post any solution they give you! When I have this issue, sometimes restarting Matlab resolves it, and it will not recur when I run the program again.

Accedi per commentare.


Sean Desten
Sean Desten il 27 Feb 2017
In my case, there were multiple worksheets in the Excel Workbook I was opening. In my code, I was opening first worksheet #1, then worksheet #2. But when opening my workbook, it was open to #2. Switching to #1 in Excel, then saving, fixed the issue.
However, I could not replicate the bug by opening up the Excel book, switching to #2 again and saving (this should have been the initial state that was causing the bug). The code proceeded to open both worksheets without any issue.
Potentially, Excel got stuck in some sort of weird state that 'locked' the worksheets and prevented them from being activated by MATLAB (I'm using locked because I don't know a better word to use - I do not mean actual locking of the worksheet). Switching worksheets and saving may have switched Excel to a more normal state. For reference, I'm using Excel 2016 and MATLAB R2016b.
  2 Commenti
Anders Simonsen
Anders Simonsen il 21 Apr 2017
Yes, switching to the first worksheet before saving solved the issue for me as well. Thanks a lot :-)
MiguelMauricio
MiguelMauricio il 4 Ago 2017
I got the same problem. I deleted some worksheets and it was solved. Thanks

Accedi per commentare.


M Zagorowska
M Zagorowska il 7 Set 2017
I have the same problem - it appears when I save something to Excel using Matlab (this part is OK), then open&close the Excel file outside Matlab, and then try to save something with Matlab to the same file (different rows/worksheet) - this is when I get 'Excel Worksheet could not be activated.' After looking into Windows Task Manager, I can see that the Excel process is not closed - so I end it manually and Matlab works again. Probably not the best way to solve it, but, hey, it works ;) Any official solution would be appreciated, though.
  3 Commenti
Shashank Singh
Shashank Singh il 5 Feb 2018
Modificato: Shashank Singh il 5 Feb 2018
This error is occurring in Windows 7 too. I have MATLAB 2016Rb and Office 365.
Cade Cockrell
Cade Cockrell il 9 Apr 2019
I belive it is due to a corrupted file. Try resaving the excel file under a different name as a new file. This worked for me

Accedi per commentare.


Ambati Lakshmipathi
Ambati Lakshmipathi il 21 Mag 2019
I am also getting error as below
Error using xlsread (line 257)
Excel Worksheet could not be activated.
i am using 2019a version

Anthony
Anthony il 1 Ott 2017
I had this error, but it was resolved after applying a MS office update that I had been dragging my feet on for some time.

Md Azimur Rahman
Md Azimur Rahman il 10 Mag 2018
I had the same issue. After Removing Foxit add-in it worked.

Flavio Ferrari
Flavio Ferrari il 10 Ott 2019
Restart Matlab (R2019a) worked for me

Kevin Rusch
Kevin Rusch il 13 Ago 2020
Can confirm that restarting worked even when
clear all;
didn't.

Wenhui Qiao
Wenhui Qiao il 1 Mar 2022
Hi, I met with the same problem and finally figured out these excels were generated and may still in use by another software. When I closed this software, my program run without that error. Thanks!

Categorie

Scopri di più su Data Import from MATLAB in Help Center e File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by