Generic battery model - State of Charge

7 views (last 30 days)
Hello everybody,
I want to use the Simulink Simscape Power Systems Battery from the "Electric Drives/Extra Sources" libarypath. To understand the model I would like to get to know why there is a gap between the "Initial state-of-charge" I write in the block parameters and the measured state-of-charge (SOC) at the beginning of the simulation. At 20 % initial SOC the measured SOC is something around 17.28 % and at 90 % intial SOC it measures 89.66 %.
Is there anyone who had the same question and solved it for himself or is anybody able to help me?
  1 Comment
essam nabil
essam nabil on 30 Apr 2019
Woud you please send me your mail. Thanks

Sign in to comment.

Accepted Answer

Zhao Wang
Zhao Wang on 8 Sep 2017
I understand that you observed the initial SOC that is different from the settings in the Battery block in the Simscape Power Systems toolbox. Based on the situation you described, I assume that you are using MATLAB R2016a or R2016b. This issue appears to be caused by a bug of the Battery block in these releases. In a more recent version of MATLAB, such as MATLAB R2017a, the initial SOC should be correct.
  1 Comment
Samuel Tepe
Samuel Tepe on 9 Sep 2017
Thanks, that safes me a lot of time.

Sign in to comment.

More Answers (0)

Communities

More Answers in the  Power Electronics Control

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by