MATLAB Answers

In the Matlab Documentation Center why do search results sometimes not display?

2 views (last 30 days)
Emily
Emily on 14 Aug 2018
Commented: Emily on 15 Aug 2018
When I search for something in the MATLAB Documentation Center, I sometimes see the results of my search, but sometimes the actual results do not display. I can see that there are results in the "refine by ..." panes on the side. Sometimes if I refine by product or something else the results will appear, but other times a little "wait for it" symbol (vertical boxes moving to the right) will appear and disappear as if they are loading, and they will remain absent. Here is a screenshot of a search with results that are not displayed. You can see that it thinks it is showing me results 1 to 10 of 29.
I'm using Matlab R2017b on a Red Hat Enterprise Linux Workstation Release 6.10 (Santiago), Kernel Linux 2.6.32-754.2.1.el6.x86_64, and GNOME 2.28.2.
  6 Comments
Emily
Emily on 15 Aug 2018
I was using 2012a, which didn't have such a fancy interface for the help docs. We have a site license, not sure when we will get the newest version installed. This problem could maybe be related to the SOFTWARE OPENGL rendering? On our system we don't have some drivers that matlab relies on for graphics so it uses software rendering instead. Also, I now recall that when I started using the newer version five months ago I had trouble with the documentation loading at all, which I fixed with the command
com.mathworks.mlwidgets.html.HtmlComponentFactory.setDefaultType('HTMLPANEL');
Using that command again does not fix the problem I'm having now. So anyway, you are right, its probably pretty specific to my system since nobody else has chimed in here. I'll see what happens with the service folks. :)

Sign in to comment.

Answers (0)

Products


Release

R2017b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by