MATLAB Answers

0

Problem with building of simulink model using embedded coder for PX4 autopilots

Asked by Tejas Rajopadhye on 5 Apr 2019
Latest activity Commented on by Tejas Rajopadhye on 23 Apr 2019
Hi,
I have been strugling with building the model code . Earlier i tried with toolchain setup with WSL(windows subsystem for linux). As the firmware didnt built many times i installed the cygwin toolchain following this https://in.mathworks.com/help/supportpkg/px4/ug/px4-using-cygwin.html. With this i was successfully able to build the firmware. I am using Pixhawk 4 and making px4fmu_v5-default .
But i couldnt build my model (see below for the model) -
With this model when use "built" i get the following errors ,
here the diagnostic viewer error's -
I think the problem lies in the "C:/PX4_CY~1/run-console_Simulink.bat" file . Can anybody tell why is this happening ?
Thanks in advance

  5 Comments

Hi Tejas,
I have attached a .ZIP file containing the updated run-console_simulink.bat file. Replace the run-console_simulink.bat file in your cygwin installation directory with the one I have shared and then try building the model.
~Abhishek
Hi Abhishek,
Diagnostic Viewer ,
Error_Matlab_built.PNG
Still getting the same error, after replacing the run-console_Simulink.bat
Is the problem that my matlab doesn't recognise CMD commands?

Sign in to comment.

Tags

1 Answer

Answer by Ankur Bose on 23 Apr 2019

Hi Tejas,
Replace the run-console_Simulink.bat file that Abhishek attached in his answer on 12 April in the Cygwin installation directory and your support package installation directory as well.
You can find the support -package directory where to replace this file by running the below commands in MATLAB command window.
cd(matlabshared.supportpkg.getSupportPackageRoot); cd toolbox\target\supportpackages\px4\lib\etc
After you have replaced the run-console_Simulink.bat in both the locations, run the below command in MATLAB comamnd window and try building the model again.
setenv('MW_PX4_WIN10_BUILDCMD', '')

  1 Comment

Thankyou Ankur for your response .
I emulated the steps that you told but the problem is the same . It doesn't build the model and outputs the same errors.

Sign in to comment.