Azzera filtri
Azzera filtri

Step size error when simulating with SimPowerSystems

2 visualizzazioni (ultimi 30 giorni)
I have a design and simulated it using Simulink. Its components belong to the SimPowerSystems blocks. When I am simulating it, I get an error and the simulation halts in the middle. The error message reads
unable to reduce step size without violating a step size of 7.3834....e-17 at 0.2034... s
I tried changing the relative tolerance in the configuration parameters, that did not work.
I am using ODE23t as my solver.

Risposta accettata

Sebastian
Sebastian il 27 Gen 2011
The "Choosing an Integration Algorithm" section of the SimPowerSystems documentation contains some hints on which solver parameters to tweak, in particular if switches and Power Electronics devices are in the model: http://www.mathworks.com/access/helpdesk/help/toolbox/physmod/powersys/ug/f7-7663.html#f7-7664
  1 Commento
Todd Flanagan
Todd Flanagan il 28 Gen 2011
Arvind says, "Thank you. I had to tweak a few parameters in the solver configuration parameters and make minor changes in my circuit component values and it worked. I also changed the solver to Ode23tb instead of Ode23t."

Accedi per commentare.

Più risposte (0)

Categorie

Scopri di più su Composite Components in Help Center e File Exchange

Tag

Non è stata ancora inserito alcun tag.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by