Azzera filtri
Azzera filtri

How do I get the pulleys in this model to rotate?

1 visualizzazione (ultimi 30 giorni)
Hello everyone, I am trying to design a 3 DoF robot arm model using Simscape and the Belts and Cables toolbox, where each link is driven with a system of cables and pulleys, set up in conveyor-like arrangements.
I am having trouble getting all the pulleys to rotate properly. I am not sure what the problem is, some pulleys seem to rotate fine while others are erratic or non-moving. I have tried joining adjacent pulleys with weld joints (to make them move together in the same manner), but that didn't work. I have considered that not defining shafts for each joint might be a problem, but I'm not sure how to do that either. I have attached the file and an image for your reference.
  2 Commenti
Yifeng Tang
Yifeng Tang il 1 Mag 2021
Ashmita, the model is missing pully.ipt and arm.ipt files, so I couldn't try to run it and see what the problem might be. Could you please include the geometry files?
Ashmita Lahiri
Ashmita Lahiri il 1 Mag 2021
Modificato: Ashmita Lahiri il 1 Mag 2021
Edit: I have attached the ipt files for the solids used in a zip file. Thanks!

Accedi per commentare.

Risposte (1)

Shubham Khatri
Shubham Khatri il 4 Mag 2021
Hello,
To my understanding, the main reason for this behavior is that the torque applied at the joints is too small to overcome the gravity. To resolve this you can turn off the gravity and actuate the revolute joints with motion instead of torque.
Hope it helps

Categorie

Scopri di più su Applications in Help Center e File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by