.m module cached in Jupyter notebook environment

1 visualizzazione (ultimi 30 giorni)
Bruce Ho
Bruce Ho il 26 Mag 2021
Commentato: Bruce Ho il 6 Giu 2021
I am using jpyter notebook with matlab engine running in the environment. I have a directory of .m files which I import using
I need to make a change to one of the files in this my_folder directory. However, everytime I ran my notebook, it still loads the old version. Even when I rename the entire directory, it still finds the old one.
I tried various techniques I found such as clear, rehash, modify using Matlab gui. nothing worked. Please tell me how to get my jupyter notebook to flush the cache and pick up the new .m file.
  4 Commenti
Bruce Ho
Bruce Ho il 6 Giu 2021
yes you can see in my original post, that I have tried clear.

Accedi per commentare.

Risposte (1)

Shubham Khatri
Shubham Khatri il 1 Giu 2021
To my understanding you are trying too many things related to MATLAB. I would recommand you to just try to restarting jupyter service and try again.
Hope it helps
  1 Commento
Bruce Ho
Bruce Ho il 6 Giu 2021
no sir. I certainly have tried that multiple times. Has anyone actually done this successfully?
I don't think "trying too many things related to MATLAB" is any thing more than your opinion. I do these things because they are needed in my environment.

Accedi per commentare.


Scopri di più su Integration with Online Platforms in Help Center e File Exchange



Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by