MATLAB Answers

Upgraded to RH Fedora 20, now my computer hostid = 00000000 and Matlab won't start

1 view (last 30 days)
Alan
Alan on 2 Feb 2014
Commented: Alan on 30 Apr 2014
This license server problem under Linux came up long ago when I first installed Matlab on my computer (no eth0 interface), and was solved by
# yum remove biosdevname
Since upgrading to Fedora 20, I ran the yum command again, but there's still no eth0 interface, and hostid still is zero, hence no Matlab.

  0 Comments

Sign in to comment.

Accepted Answer

Bernard
Bernard on 30 Apr 2014
It works with fedora 20 !
The easiest way to restore the old way Kernel/modules/udev rename your ethernet interfaces is supplying these kernel parameters to Fedora 19:
net.ifnames=0
biosdevname=0
To do so follow this steps:
Edit /etc/default/grub
At the end of GRUB_CMDLINE_LINUX line append "net.ifnames=0 biosdevname=0"
Save the file
Type "grub2-mkconfig -o /boot/grub2/grub.cfg"
Type "reboot"
If you didn't supply these parameters during the installation, you will probably need to adjust and/or rename interface files at /etc/sysconfig/network-scripts/ifcfg-*.
Up to Fedora 18, just biosdevname=0 was enough.
As an example, in a certain machine, in a exhaustive research, I got:
-No parameters: NIC identified as "enp5s2". -Parameter biosdevname=0: NIC identified as "enp5s2". -Parameter net.ifnames=0: NIC identified as "em1". -Parameter net.ifnames=0 AND biosdevname=0: NIC identified as "eth0".

More Answers (0)


Translated by