MATLAB Answers

0

Raspi.m : Do we have the right code to connect with the Raspberry PI2 ?

Asked by Walter Knell on 27 Jun 2015
Latest activity Commented on by wasted
on 29 Jul 2016
I speak about the raspi.m version with date 13.02.2015
Some facts:
1. Raspi.m is unable to connect with a proper installed Raspbian wheezy with a running sshd and a running MATLABserver. ping and external ssh-client (putty) function. firewall on windows (Windows 8.1) paused.
With rpi = raspi();
i get the error message:
"Error using raspi (line 153)
Error executing command: Die Syntax fr den Dateinamen, Verzeichnisnamen oder die Datentr„gerbezeichnung
ist falsch. "
Seems there is a problem with a filename, directory name etc. , not with the ip-address or the username or the password.
What is in line 153 of the raspi.m ?
connect(obj.Ssh, ['echo `pgrep MATLABserver` | sudo tee /tmp/.' hashKey]);
Is there an error in ?
I tried this code on the board and i got an output like "1616" (i think this is the hashKey).
My conclusion is now : the above code is unable to get this hashKey, thinks there is no running MATLABserver, stops further connection trials and delivers the above cited error code.
2. Trying Simulink-raspberry-examples :
Sendig the model to the Raspberry board livers:
a) the incoming (login etc.) and acception by the sshd can be read in the var/log/auth.log
b) but followed by a logout immediately
and the same error-code as above mentioned.
Conclusion: no problem with the login of the ssh-client ! the connection with the running MALABserver fails
These are my facts.
Now my questions.
1. Has someone got the same error-code and could not connect ?
2. What is the reaction of the matlab-support if he was informed ?
3. What is the solution / the work-around of the (i think: errornious) code in line 153 ?
Has someone a working solution ?
Summary: With the actual raspi.m and the actual raspian wheezy from the matlab-download (with the MATLABserver running in) i am not able to work with: worthless !!!. With working network etc. etc.
And i think it is a general problem with this connecting-code ; see above.
An update is needed !!!
Hope insiders, developpers etc. can give comments /answers immediately.
Kind regards
Walter Knell

  3 Comments

Hi! I have the same problem. You can check it here:
https://www.mathworks.com/matlabcentral/answers/254313-rapberry-pi-connection-problem-error-raspi-cannot-establish-a-tcp-ip-connection
Do you know how to solve it?
dear Walter,
i hv the same windows configuration 8.1 64bit n currently i m facing the same problem with raspberry pi . please help me out.
For me this worked out:
open Matlab via Terminal (Mac) or cmd.exe (Windows)
On Mac: Enter the following: sudo open /Applications/Matlab_R2015a.app/
On Videos there should be a similar command for opening applications in admin mode. Matlab wasn't able to connect via SSH without opening the app in admin mode.

Sign in to comment.

0 Answers