Azzera filtri
Azzera filtri

Simulink Desktop Real-Time Sync block (Matlab 2016b) seems to cause my PC to crash. Is this a reported problem? Any Fix?

5 visualizzazioni (ultimi 30 giorni)
This problem appears at random, but is has happened several times on both my laptop and PC (both running Windows 10). When running even simple models (i.e. Sine source to scope) with the real-time sync block, my PC will unexpectedly crash requiring a hard reset. Is this a problem with how the real-time kernel works with my PC clock? Is this a problem anyone else is experiencing, and is there a fix?
  3 Commenti
Wolfgang Birk
Wolfgang Birk il 23 Nov 2017
Modificato: Wolfgang Birk il 23 Nov 2017
We have the same problem on 2017a. working national instruments A/D cards. Random crashes and there is no way to recover. The PC has to be restarted with a hard reset.
We used our setup for 5 years with real time kernel and did not get any problems. Now we have upgraded to windows 10 and Matlab 2017a.
Note: There were no problems with windows 7 Enterprise and Matlab 2015b.

Accedi per commentare.

Risposte (7)

Wolfgang Birk
Wolfgang Birk il 6 Feb 2018
We have found out that the CPU throttling settings seem to be highly related to the crashes. When we disabled the CPU throttling the crashes have disappeared on all the machines that we use in our lab.
  1 Commento
Simo Simolin
Simo Simolin il 7 Feb 2018
Great that you found a solution to this problem! Did you disable throttling from computer settings or could it somehow be disabled from Matlab/Simulink settings?

Accedi per commentare.


vestel06
vestel06 il 30 Mag 2017
I faced with the same problem too. is there any solution ?
  1 Commento
Jameson
Jameson il 1 Lug 2017
Sorry for not responding earlier. They looked at my crash dump file and found nothing to do with Matlab.. but it is not solved. I ended up scratching Matlab project and writing Ros nodes directly. Trying to use real time sync with Matlab for my purpose was too much hassle and no one seems to know why it happens so. Sorry about that.

Accedi per commentare.


Andrea Pisculli
Andrea Pisculli il 1 Lug 2017
I have the same problem.
  1 Commento
Jameson
Jameson il 1 Lug 2017
As with previous comment Matlab could not find any link to their software and the constant crashes. I don't think it is worth it to continue trying to use real time sync block for my purpose, but maybe they can try to help your problem? Sorry I can't help.

Accedi per commentare.


Roberto
Roberto il 12 Ott 2017
Same problem here. I guess I'll try to update Matlab&Simulink, keeping fingers crossed.

Simo Simolin
Simo Simolin il 5 Feb 2018
Modificato: Simo Simolin il 5 Feb 2018
Exactly same problem here (Matlab R2017b, Windows 10). Computer crashes several times per day even with simple models but randomly same models work without any problem. Did anyone find a solution?
Sometimes model gets stuck to "Initializing" phase when trying to run it in External mode and sometimes it succeeds to start the external mode but gets stuck to "t=0.000". Even Task Manager freezes when this happens and hard reset is the only way to recover.

Sviatoslav Klos
Sviatoslav Klos il 12 Feb 2018
https://www.mathworks.com/support/bugreports/1719571

Nils Hintzen
Nils Hintzen il 22 Ago 2018
Hi, has anyone solved this problem by the answer of Sviatoslav Klos? I have updated Matlab to 2018a and have a similar problem. Here ist the link to my question:
https://de.mathworks.com/matlabcentral/answers/415660-problem-to-acquire-data-in-simulink-external-mode-2018a-in-combination-with-an-i-o-device
Nils

Categorie

Scopri di più su Multicore Processor Targets in Help Center e File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by