Co-simulation with HDL verifier and Modelsim version

1 view (last 30 days)
I have just a question about modelsim version supported with EDA Simulator link(HDL verifier). At documentation it says
--Use one of the following recommended versions. Each version has been --fully tested against the current release:
--ModelSim SE 10.0c, 6.6d, 6.5f
--ModelSim PE 10.0c, 6.6d, 6.5f
--ModelSim DE 10.0c
Does that mean that these version are exclusive? Wouldn't recent version support the cosimulation(like 10.0D)?
And what about getting simulink operating in windows xp and modelsim at a linux? Would the socket method work between two different machines?
Best regards for answers.

Accepted Answer

Tao Jia
Tao Jia on 18 Sep 2012
The list of supported ModelSim versions are not exclusive. Other versions of ModelSim SE/PE/DE are likely to be compatible, but there is no guarantee.
When new ModelSim versions come out, most of them are compatible with HDL Verifier. They are not listed here since they have now been fully tested with HDL Verifier yet. In some rare cases, the new ModelSim version contains changed API that breaks the compatibility. When that happens, the problem will be fixed in newer version of HDL Verifier or via a patch.
For your last question, you can do cross-network cosimulation with Simulink running on Windows and ModelSim running on Linux. See HDL Verifier documentation here: http://www.mathworks.com/help/hdlverifier/ug/startup-procedures-for-hdl-cosimulation.html#bst4x6q-1
  1 Comment
Mohamed-Helmi
Mohamed-Helmi on 20 Sep 2012
Thanks a lot for your response, it was quite explained, but I would rather be sure about acquiring such a licensed version, because I doubt that the source code in matlab/simulink is requiring these version for having successful the configuration between modelsim and HDL verifier.

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by