Azzera filtri
Azzera filtri

subscript that is out of range?

5 visualizzazioni (ultimi 30 giorni)
Rajeev Kumar
Rajeev Kumar il 18 Set 2020
Commentato: stozaki il 21 Set 2020
I tried to simulate matrix equations with simulink but "subscript is out of range" error display. Anyone pls fix it.
attachment : simulink file

Risposta accettata

stozaki il 19 Set 2020
Hello Rajeev,
The variable "P" is undefined in your Fcn block.
Define the value of the variable "P".
  2 Commenti
Rajeev Kumar
Rajeev Kumar il 21 Set 2020
I defined the P variable but same error displayed again.
stozaki il 21 Set 2020
Is it the same error? Isn't it a different error message?
I seem to have the wrong number of elements in your Fcn block. Since the output of the Demux block is scalar, I don't think u (2) or u (3) can be used.
I think the input of the Fcn block can remain a vector. I have attached a reference example.

Accedi per commentare.

Più risposte (0)




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by