MATLAB Answers

Dr. Seis

Not able to run Matlab Standalone Executable

Asked by Dr. Seis
on 13 Jun 2013
I have several Matlab functions that I have turned into standalone executables and have had success running them on several different machines (all Unix) in the not-so-distant past. All of a sudden I cannot run these programs and get the message:
Could not access the MCR component cache.
The weird part is that other people are able to run these standalone executables on their remote machines, but even if I log into their remote machines using my own user credentials I cannot get it to run.
It does not make sense that this message would pop up for me, but not for someone else logged on to the same machine.
Any ideas?


Sign in to comment.

2 Answers

Answer by Kaustubha Govind on 13 Jun 2013
 Accepted Answer

Please look at this previous answer.


Show 1 older comment
I updated the Answer that Kaustubha linked to.
I am running Matlab on a Linux workstation. These .mcrCache* were directories that were located inside my "home" directory (e.g., /home/{user name}) instead of my Matlab working directory (e.g., /home/{user name}/Matlab).
Once I deleted all the directories, the problem was resolved.
... Well I thought it was resolved. Now even after deleting the .mcrCache* directories, I still get the same error as above.
Not sure what is going on.

Sign in to comment.

Answer by Dr. Seis
on 16 Jun 2013
Edited by Dr. Seis
on 16 Jun 2013

.mcrCache* files getting corrupted turned out to be the symptom rather than the cause of my issues.
The actual reason (as I just discovered) is a disk quota issue that might also manifest itself as a permissions issue. Where I work, there is tons of disk space except for our "home" directories - we are only given 2GB of space for our home directory. What had happened is that during the course of testing a program (which was writing out a fairly large text file) it had caused my disk space to exceed my 2GB quota (which I didn't realize immediately). I was also receiving an error in the command window:
The desktop configuration was not saved successfully
... which (from documentation) usually pops up with permissions issues and disk space issues.

  1 Comment

Thanks for posting your findings!

Sign in to comment.