Azzera filtri
Azzera filtri

Plot legend does not display any lines

122 visualizzazioni (ultimi 30 giorni)
Hi,
I am plotting a simple graph from a matrix, but when I code as below, the legend does not show any lines, but shows legend names only.
plot(kmat,v(:,1))
title('Convergence of Value Functions')
xlabel('k')
ylabel('v(k)')
hold on
plot(kmat,v(:,5))
plot(kmat,v(:,50))
plot(kmat,v(:,1000))
legend('iter=1','iter=5','iter=50','iter=1000')
hold off
"kmat" is N x 1 matrix for x-axis value, and "v" is N x N matrix where i want to plot values on y-axis.
However, as you can see from the plot below, the legend displays its names but doesn't display any corresponding line.
legend_problem.png
  13 Commenti
Star Strider
Star Strider il 17 Nov 2020
Paul Stansell —
I have no idea what the problem actually was. I updated the driver (using the ‘Auto-Detect and Install Radeon™ Graphics Drivers for Windows®’ app on the AMD Drivers and Support site) and after that, everything worked as it should, on both my desktop and laptop (both Ryzen+Radeon). There are several posts about this, and in every situation, upgrading the graphics driver solved the problem.
Matthew Fracalanza
Matthew Fracalanza il 22 Feb 2021
Modificato: Matthew Fracalanza il 22 Feb 2021
That worked, Star Strider. Thanks so much.

Accedi per commentare.

Risposta accettata

darova
darova il 3 Ott 2019
Please see THIS solution for colorbar error

Più risposte (4)

Benoit Schiltz
Benoit Schiltz il 16 Set 2020
Hi,
I have the same problem which was solved using
opengl software
But doing that makes the lines of the plot pixelized (this effect was not a problem before) displaying very little stairs between almost each step. Is there a way to fix this? I tried using
opengl hardware
Which solved the problem of the smoothness of the curves but then the legend colors and box disappeared.
Thanks

Paul Stansell
Paul Stansell il 17 Nov 2020
Modificato: Paul Stansell il 17 Nov 2020
I have recently had a similar problem. opengl('save','software') did not work for me. Specifying ...'LineWidth',1) did. No idea why! (Actually, a line width >= 0.8 worked)
  5 Commenti
christos d
christos d il 13 Gen 2021
I can confirm that the issue is still there in matlab 2020b. But I can also confirm that using exactly the same laptop in other script it displays the dots of the legend the way it should. The script that I noticed it has the issue, happens to be a function file with nested function that provides results running it directly from the function file. I am not sure if it has to do with the matlab type of file or not, probably not.I do have an AMD processor by the way.
Siphiwo Mzekandaba
Siphiwo Mzekandaba il 1 Ott 2023
I am using R2021a, specifying ...'LineWidth', 1) worked for me.

Accedi per commentare.


Sergio Sanz
Sergio Sanz il 3 Apr 2020
I have the same problem and I've found that it only happens when lines are 0.5 width. If you change to 1 You can see both the edge of the legend and the lines of data inside the legend.
But I don't know what's the problem.
That's only a provisional solution.
  2 Commenti
parson fu
parson fu il 23 Mag 2020
I see the same problem too,but in another computer,it works fine.
PAVEL
PAVEL il 10 Set 2022
It's a really solution, I just want to add it's neccessary to specify 'LineWidth' for each of plots for proper work.

Accedi per commentare.


Aisha Alshamrani
Aisha Alshamrani il 24 Mar 2021
I have the same problem , i try to use opengl but it didn’t work
  1 Commento
Adam Danz
Adam Danz il 24 Mar 2021
Modificato: Adam Danz il 24 Mar 2021
See Paul's answer on this page or Star Strider's answer in another thread.

Accedi per commentare.

Prodotti


Release

R2019b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by